Microsoft SC-200 Exam Actual Questions
Microsoft Security Operations Analyst (Page 8 )

Updated On: 7-Aug-2026

HOTSPOT (Drag and Drop is not supported)
You have a Microsoft 365 E5 subscription that uses Microsoft Defender XDR.
Your network contains an on-premises Active Directory Domain Services (AD DS) domain that syncs with a Microsoft Entra tenant.
You need to identify LDAP requests by AD DS users to enumerate AD DS objects.
How should you complete the KQL query? To answer, select the appropriate options in the answer area.
Note: Each correct selection is worth one point.
Hot Area:

  1. See Explanation section for answer.

Answer(s): A

Explanation:




Box 1: IdentityQueryEvents The IdentityQueryEvents table in the advanced hunting schema contains information about queries performed against Active Directory objects, such as users, groups, devices, and domains.
Box 2: isnotempty
Example: IdentityQueryEvents | where isnotempty(AccountSid) | take 100
// IdentityQueryEvents // - contains query activities performed against Active Directory objects, such as users, groups, devices, and domains monitored by Azure ATP // - Includes SAMR, DNS and LDAP requests
// ---------------
Incorrect: * IdentityInfo The IdentityInfo table in the advanced hunting schema contains information about user accounts obtained from various services, including Azure Active Directory.
* IdentityDirectoryEvents IdentityDirectoryEvents The IdentityDirectoryEvents table in the advanced hunting schema contains events involving an on-premises domain controller running Active Directory (AD). This table captures various identity-related events, like password changes, password expiration, and user principal name (UPN) changes. It also captures system events on the domain controller, like scheduling of tasks and PowerShell activity.


Reference:

https://learn.microsoft.com/en-us/microsoft-365/security/defender/advanced-hunting-identityqueryevents-table https://learn.microsoft.com/en-us/microsoft-365/security/defender/advanced-hunting-identitydirectoryevents-table https://github.com/microsoft/Microsoft-365-Defender-Hunting-Queries/blob/master/Webcasts/ TrackingTheAdversary/Episode%201%20-%20KQL%20Fundamentals.txt



You have a Microsoft 365 E5 subscription that uses Microsoft Defender XDR.
You need to ensure that you can investigate threats by using data in the unified audit log of Microsoft Defender for Cloud Apps.
What should you configure first?

  1. the User enrichment settings
  2. the Azure connector
  3. the Microsoft 365 connector
  4. the Automatic log upload settings

Answer(s): C

Explanation:

How to connect Microsoft 365 to Defender for Cloud Apps 1. In the Microsoft 365 Defender portal, select Settings. Then choose Cloud Apps. Under Connected apps, select App Connectors.
2. In the App connectors page, select +Connect an app, and then select Microsoft 365.

3. In the Select Microsoft 365 components page, select the options you require, and then select Connect.

4. On the Follow the link page, select Connect Microsoft 365.
5. After Microsoft 365 is displayed as successfully connected, select Done.
6. In the Microsoft 365 Defender portal, select Settings. Then choose Cloud Apps. Under Connected apps, select App Connectors. Make sure the status of the connected App Connector is Connected.


Reference:

https://learn.microsoft.com/en-us/defender-cloud-apps/connect-office-365



HOTSPOT (Drag and Drop is not supported)
You have a custom Microsoft Defender XDR detection rule that includes the following KQL query.

For each of the following statements, select Yes if True. Otherwise, select No.
Note: Each correct selection is worth one point.
Hot Area:

  1. See Explanation section for answer.

Answer(s): A

Explanation:



You have an Azure subscription that uses Microsoft Defender for Servers Plan 1 and contains a server named Server1.
You enable agentless scanning.
You need to prevent Server1 from being scanned. The solution must minimize administrative effort.
What should you do?

  1. Create an exclusion tag.
  2. Upgrade the subscription to Defender for Servers Plan 2.
  3. Create a governance rule.
  4. Create an exclusion group.

Answer(s): A

Explanation:

Exclude machines from scanning Agentless scanning applies to all of the eligible machines in the subscription. To prevent specific machines from being scanned, you can exclude machines from agentless scanning based on your pre-existing environment tags.
When Defender for Cloud performs the continuous discovery for machines, excluded machines are skipped.
To configure machines for exclusion:
1. From Defender for Cloud's menu, open Environment settings.
2. Select the relevant subscription or multicloud connector.
3. For either the Defender Cloud Security Posture Management (CSPM) or Defender for Servers P2 plan, select Settings.
4. For agentless scanning, select Edit configuration.
5. Enter the tag name and value that applies to the machines that you want to exempt. You can enter multiple tag:value pairs.

6. Select Save to apply the changes.
Note: Defender for Servers Plan 1 is entry-level and must be enabled at the subscription level.
Features include: Foundational cloud security posture management (CSPM), which is provided free by Defender for Cloud.
Defender for Servers Plan 2 provides all features. The plan must be enabled at the subscription level and at the workspace level to get full feature coverage. Features include:
All the functionality that's provided by Defender for Servers Plan 1. More extended detection and response (XDR) capabilities.


Reference:

https://learn.microsoft.com/en-us/azure/defender-for-cloud/enable-agentless-scanning-vms#exclude-machines-from-scanning https://learn.microsoft.com/en-us/azure/defender-for-cloud/plan-defender-for-servers-select-plan



You need to configure Microsoft Defender for Cloud Apps to generate alerts and trigger remediation actions in response to external sharing of confidential files.
Which two actions should you perform in the Microsoft Defender portal? Each correct answer presents part of the solution.
Note: Each correct selection is worth one point.

  1. From Settings, select Information Protection, select Azure Information Protection, and then select Only scan files for Azure Information Protection classification labels and content inspection warnings from this tenant.
  2. From Cloud apps, select Files, and then filter File Type to Document.
  3. From Settings, select Information Protection, select Files, and then enable file monitoring.
  4. From Cloud apps, select Files, and then filter App to Office 365.
  5. From Cloud apps, select Files, and then select New policy from search.
  6. From Settings, select Information Protection, select Azure Information Protection, and then select Automatically scan new files for Azure Information Protection classification labels and content inspection warnings.

Answer(s): B,F

Explanation:

Discover and protect sensitive information in your organization
Phase 1: Discover your data Details omitted.
(D) Phase 2: Classify sensitive information 1. Define which information is sensitive. Details omitted.
2. Enable Microsoft Information Protection integration a. In the Microsoft 365 Defender portal, select Settings. Then choose Cloud Apps. b. Under Information Protection, go to Microsoft Information Protection. Select Automatically scan new files for Microsoft Information Protection sensitivity labels and content inspection warnings.

3. Etc.
Phase 3: Protect your data
Phase 4: Monitor and report on your data
E: File filters in Microsoft Defender for Cloud Apps File monitoring should be enabled in Settings. In the Microsoft 365 Defender portal, select Settings. Then choose Cloud Apps. Under Information Protection, select Files. Select Enable file monitoring and then select Save.
Note: To provide data protection, Microsoft Defender for Cloud Apps gives you visibility into all the files from your connected apps. After you connect Microsoft Defender for Cloud Apps to an app using the App connector, Microsoft Defender for Cloud Apps scans all the files, for example all the files stored in OneDrive and
Salesforce. Then, Defender for Cloud Apps rescans each file every time it's modified – the modification can be to content, metadata, or sharing permissions. Scanning times depend on the number of files stored in your app. You can also use the Files page to filter files to investigate what kind of data is saved in your cloud apps.
('Microsoft 365 Defender' and 'Microsoft Defender XDR' are just terminologies used to group different platforms together.)


Reference:

https://docs.microsoft.com/en-us/cloud-app-security/tutorial-dlp https://docs.microsoft.com/en-us/cloud-app-security/azip-integration https://learn.microsoft.com/en-us/defender-cloud-apps/file-filters



HOTSPOT (Drag and Drop is not supported)
Your network contains an on-premises Active Directory Domain Services (AD DS) domain that syncs with a Microsoft Entra tenant.
You have a Microsoft 365 E5 subscription that uses Microsoft Defender 365.
You need to identify all the interactive authentication attempts by the users in the finance department of your company.
How should you complete the KQL query? To answer, select the appropriate options in the answer area.
Note: Each correct selection is worth one point.
Hot Area:

  1. See Explanation section for answer.

Answer(s): A

Explanation:




Box 1: IdentityInfo Example: IdentityInfo | where JobTitle == "CONSULTANT" | join hint.shufflekey = AccountObjectId (IdentityDirectoryEvents | where Application == "Active Directory" | where ActionType == "Private data retrieval") on AccountObjectId
Note: The IdentityInfo table in the advanced hunting schema contains information about user accounts obtained from various services, including Azure Active Directory. Use this reference to construct queries that return information from this table.
* AccountObjectId Unique identifier for the account in Azure AD
* Department Name of the department that the account user belongs to
Box 2: IdentityLogonEvents The IdentityLogonEvents table in the advanced hunting schema contains information about authentication activities made through your on-premises Active Directory captured by Microsoft Defender for Identity and authentication activities related to Microsoft online services captured by Microsoft Defender for Cloud Apps.
Column names include: * AccountObjectId Unique identifier for the account in Azure AD
* Etc.
Incorrect: * Audit Logs (User and group management activity)
* SignInLogs (Authentication Activity)


Reference:

https://learn.microsoft.com/en-us/microsoft-365/security/defender/advanced-hunting-identityinfo-table https://learn.microsoft.com/en-us/microsoft-365/security/defender/advanced-hunting-identitylogonevents-table



You have a Microsoft 365 E5 subscription that uses Microsoft Defender for Endpoint.
You need to identify any devices that triggered a malware alert and collect evidence related to the alert. The solution must ensure that you can use the results to initiate device isolation for the affected devices.
What should you use in the Microsoft 365 Defender portal?

  1. incidents
  2. Remediation
  3. Investigations
  4. Advanced hunting

Answer(s): D



HOTSPOT (Drag and Drop is not supported)
You have a Microsoft 365 E5 subscription that uses Microsoft Purview and contains a user named User1.
User1 shares a Microsoft Power BI report file from the Microsoft OneDrive folder of your company to an external user by using Microsoft Teams.
You need to identify which Power BI report file was shared.
How should you configure the search? To answer, select the appropriate options in the answer area.
Note: Each correct selection is worth one point.
Hot Area:

  1. See Explanation section for answer.

Answer(s): A

Explanation:




Box 1: Share file, folder, or site Activities
Box 2: Shared Power BI report Record type
Box 3: Microsoft teams Workload
Note: Search-UnifiedAuditLog Applies to: Exchange Online, Exchange Online Protection This cmdlet is available only in the cloud-based service.
Use the Search-UnifiedAuditLog cmdlet to search the unified audit log. This log contains events from Exchange Online, SharePoint Online, OneDrive for Business, Azure Active Directory, Microsoft Teams, Power BI, and other Microsoft 365 services. You can search for all events in a specified date range, or you can filter the results based on specific criteria, such as the user who performed the action, the action, or the target object.
Example: Search-UnifiedAuditLog -StartDate 5/1/2018 -EndDate 5/8/2018 -RecordType SharePointFileOperation -Operations FileAccessed -SessionId "WordDocs_SharepointViews"-SessionCommand ReturnLargeSet
This example searches the unified audit log for any files accessed in SharePoint Online from May 1, 2018 to May 8, 2018. The data is returned in pages as the command is rerun sequentially while using the same SessionId value.


Reference:

https://learn.microsoft.com/en-us/microsoft-365/security/defender/auditing https://learn.microsoft.com/en-us/powershell/module/exchange/search-unifiedauditlog



Viewing page 8 of 61
Viewing questions 57 - 64 out of 478 questions


Post your Comments and Discuss Microsoft SC-200 exam prep with other Community members:

AI Tutor AI Tutor 👋 I’m here to help!